Installation

From Evolution-plugins
Jump to: navigation, search

How to install

You'll need a pretty new version of evolution in order to build.

Unpack evolution-rss-0.X.Y.tar.gz.


Users of Unbuntu, firstly make sure you have following installed (apt-get)

- build-essential
- intltool
- evolution-dev
- libebook1.2-dev
- libsoup2.4-dev 
- libgtkhtml3.14-dev
- libdbus-glib-1-dev (for evolution-import-rss support)

For Gecko and Webkit support (evolution-rss >= 0.0.5)

- xulrunner-1.9-dev (or for older libxul-dev)
- libwebkitgtk-dev


Users of Fedora, make sure you have following installed (yum)

- gcc
- perl-XML-Parser
- automake 
- gettext
- gcc-c++
- evolution-devel
- evolution-data-server-devel
- glib2-devel
- libsoup-devel
- intltool 
- libtool 

For Gecko support (evolution-rss >= 0.0.5)

- firefox-devel (fedora <= 8)
- xulrunner-devel-unstable (fedora >= 9)

Gecko support for users of SLED, openSuse, etc

- gecko-sdk


Run:

cd /path/to/extracted/directory
./configure --prefix=/usr
make
make install

then enable Evolution Rss under Edit->Plugins and you are all setup.


Evolution-RSS displaying an article

      * Rendering with Gecko support.
      Evo-rss-gtkmozembed.jpg
Evolution-rss.png